HELP..Engine Quits under Load !?!?!

Discussion in 'Tech Area' started by Maritimermitch, May 4, 2010.

  1. Maritimermitch

    Maritimermitch New Member

    Joined:
    May 4, 2010
    Messages:
    19
    Likes Received:
    0
    ITS A 1982 HONDA CT70. it idles fine but when i rev it or try to drive it, it bogs out or quits. what could be the problem? it smokes but i have new rings on order but they wont be in for another month or so from the honda dealer. could it be the rings causing this problem or could it be something else like low spark caused from the plug or the plug wire or the coil etc? PLEASE HELP
     
  2.  
  3. Grant's trail

    Grant's trail Member

    Joined:
    Jul 20, 2008
    Messages:
    899
    Likes Received:
    15
    I would clean the main jet in the carb and jet holder too, make sure all the little holes on the sides are clear. Also is the air cleaner clean?
     
    Flash likes this.
  4. Maritimermitch

    Maritimermitch New Member

    Joined:
    May 4, 2010
    Messages:
    19
    Likes Received:
    0
    I will sure try it man ! thank you any help is better than no help. also if any1 had any good websites to buy ct70 parts that accept paypal and isnt too expensive on items or shipping would be great also !!!

    ---------- Post added at 11:10 AM ---------- Previous post was at 11:08 AM ----------

    the air filter is clean. it runs the same with the filter on or off. it doesnt seem to bog out when the choke is on but it clearly doesnt have any power because it has no air lol. also i forgot to mention that it just started doing this boggin out thing randomly. i was driving it wide open 1 day and it just started acting like a peice of sh*t !!!
     
  5. a_smerek

    a_smerek Member

    Joined:
    Feb 17, 2008
    Messages:
    815
    Likes Received:
    3
    I have a CT70 that does this when dirt collects in the fuel inlet of the carb. It happens a few times a year

    Clean the whole carb, thoroughly, and give the engine a compression test

    Checking the valve lash is not a bad idea either
     
  6. Maritimermitch

    Maritimermitch New Member

    Joined:
    May 4, 2010
    Messages:
    19
    Likes Received:
    0
    i will defintly try and clean the carb and see if that fixes the problem. it does have lots of compression but it does smoke so i figured it wouldnt hurt to have new rings. it will start first kick every time usually. where is the best place to get a carb gasket set
     
  7. racerx

    racerx Administrator
    Staff Member Administrator

    Joined:
    Jul 10, 2005
    Messages:
    14,684
    Likes Received:
    1,647
    The smoking could be a leaky valve seal, or seals. You should plan on valve seal replacement with a rebuild anyway. If the cylinder walls look good, it might make sense to try new valve seal(s) alone and see what happens. Take a look at your intake port. If it's black, chances are good that the intake valve is "mushroomed" and should be replaced. That won't make the engine smoke, but indicates reversion, from pressurized gases leaking past the intake valve, into the intake port which won't help performance.
     
  8. Maritimermitch

    Maritimermitch New Member

    Joined:
    May 4, 2010
    Messages:
    19
    Likes Received:
    0
    would a hole in the float be the problem maybe? ha hA
     
  9. bjatwood

    bjatwood 120cc

    Joined:
    Jun 19, 2007
    Messages:
    1,885
    Likes Received:
    6
    In a word YES! omes to mind.
    Change it out and put a new needle valve in it when you do the float too.
     
  10. Maritimermitch

    Maritimermitch New Member

    Joined:
    May 4, 2010
    Messages:
    19
    Likes Received:
    0
    i will let everyone know how i made out when my engine gaskets get here and i install them and than put my carb on
     
  11. Maritimermitch

    Maritimermitch New Member

    Joined:
    May 4, 2010
    Messages:
    19
    Likes Received:
    0
    Hello, i tore the carb apart to find it was dirty and the float had a hole in it. i soldered the float and cleaned the carn nicely. i put new piston rings and top end gaskets including the head gasket. i also put a new spark plug and the bike seems to work A1!
     

Share This Page