Some help needed on c70

Discussion in 'General' started by Ethan, Jun 30, 2018.

  1. Ethan

    Ethan New Member

    Joined:
    Jun 28, 2018
    Messages:
    2
    Likes Received:
    0
    Hey beautiful folks! I've been restoring a c70 off and on for a year now. I'm mainly trying to get the electrical sorted out. What I want is the electric starter to work. I replaced the relay that sends current to the starter but there's no current coming out the opposite terminal? I know the nuetral switch is fine cause the light is on and I can feel something clicking over in the relay. What else I'm I missing? The old relay was much larger so maybe it was the wrong one?? Thanks in advance!
     
  2.  
  3. bruces

    bruces Active Member

    Joined:
    Sep 10, 2013
    Messages:
    461
    Likes Received:
    86
    Is your new relay and old relay the same voltage ?
     
  4. kirrbby

    kirrbby Well-Known Member

    Joined:
    May 28, 2009
    Messages:
    8,734
    Likes Received:
    1,076
  5. Ethan

    Ethan New Member

    Joined:
    Jun 28, 2018
    Messages:
    2
    Likes Received:
    0
    Thank you thank you!! I really need to sit down and make sense of this but I appreciate the leads so far!!!
     
  6. whereshaldo

    whereshaldo Member

    Joined:
    Jan 23, 2018
    Messages:
    57
    Likes Received:
    6
  7. Karl81

    Karl81 New Member

    Joined:
    Saturday
    Messages:
    7
    Likes Received:
    0
    They stick. They take a hot battery. The more you use them the less trouble you will have.
    I was just about to take mine apart and see what I could do about it after getting a new relay, checking all the other thing and it started to bump a little. I kept clicking it for half hour even running the battery down buy it freed it up. It still hangs if I don't use crank on it after letting the bike set for awhile. Maybe I'll lube it one day.
     

Share This Page