Stupid question on tank mount rubber bushings.

deezil

New Member
Im rebuilding a 1978 z50 I bought in apart and in literal baskets..

The tank bushings that came with it are in good shape and not dry rotted out. The issue I have is the frame posts to mount the bushings are way undersized and the front rubber bushings or whatever they are called don't fit snugly on the posts. There's a absolute ton of slop between the posts on the frame to the ID of the bushings. Was there a collar/spacer or something that was supposed slip into the rubber bushings to make up the difference between the hole in the bushings to the OD of the frame posts? When I look for new bushings the seller states the mounting hole to be the same as my original parts! This is a original 1978 z50 frame and not a aftermarket frame if that helps.



Silly question I know,,, Any input you all can give?
 

kirrbby

Well-Known Member
You probably have the wrong rubbers. The 78 probably has ¼" posts on the frame...6mm whatever...
There are some other, newer bikes that had bigger posts...pretty sure.
If you buy new rubbers...for 70-79ish z50s...they will be about ¼ id and maybe ⅝ od.
 

kirrbby

Well-Known Member
They must have changed in 79. See the posts on this 79 frame...

1653392103613.png
 

kirrbby

Well-Known Member
Well shoot! Alright I guess I'll get thise ordered as well. Thank you all!
It's a pretty dumb little job that they do. You cold make them work...as loopie said. You can whittle down the od if necessary...with a knife or sander, etc. You cold make some...maybe by wrapping a strip of old inner tube...or whatever, around a bolt...super glue works pretty well on rubber...or rubber cement of course. You could make some out of wood, felt, dirty shop rag. All they need to do is work, and not wear a hole into the tank. They don't really show or anything.
 
Top